Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
zarinaa2004
06.06.2022 11:56 •
Информатика
Вцелочисленном массиве a(15), заданном случайным образом найти количество элементов, больших 10.
Ответ:
marylist2005
03.10.2020 07:47
1. Вот так это нужно решать по-современному
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
Writeln('k=',ArrRandom(15,1,20).Println.Count(x->x>10))
end.
Тестовое решение
4 16 14 9 11 18 17 14 14 15 1 1 9 10 15
k=9
2. А вот так учат решать в школе...
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
var
a:array[1..15] of integer;
i,k:integer;
begin
Randomize;
k:=0;
for i:=1 to 15 do begin
a[i]:=Random(20)+1;
Write(a[i],' ');
if a[i]>10 then k:=k+1
end;
Writeln;
Writeln('k=',k)
end.
Тестовое решение:
18 15 7 6 3 3 10 6 6 15 2 16 16 2 12
k=6
0,0
(0 оценок)
Популярные вопросы: Информатика
Stepka112
01.07.2021 13:03
Составьте программу вычисления суммы элементов массива ,стоящих на четных местах...
zLimboz
10.09.2021 06:19
Сделать в pascal вычислите выражение при заданных константах: a=10.2; b=9.2; x=2.2; c=0.5;...
BloodRainbow
10.09.2021 06:19
Составить алгоритм подсчета суммы s первых 1000 членов гармонии 1+1/2+1/3+1/+ 1/n используя цикл с предисловием нужна только блок схема...
DathVayolet
02.09.2020 10:38
Какие наушники лучше Bluetooth или проводные...
danila9988p09k31
08.08.2021 07:13
(Информатика)Укажіть, чи подана нижче формула записана правильно, чи ні: =AVERAGE(А1, В1, С1)...
Шишиuvuvgyuhuh
06.09.2020 03:04
2. Определите устройства компьютера 21 Это устройство называют лазеом компьютера. Его основными функциямиявляютсяобработкаинформацииВычислительныеработы22 Это устройство, предназначенное...
PomogitePLS111
28.06.2022 21:25
Возможно ли присваивание глобальной переменной значения формального параметра? ответ поясните примером....
Натали2004абвг
29.04.2022 04:59
Как вывести 5 раз окно сообщений в паскаль...
danilpov
28.04.2020 09:26
НУЖЕН ОТВЕТ Запиши IP-адрес, если известно, что IP подсети: 114.81.0.0 IP хоста: 0.0.183.223 IP-адрес:...
SofiaAM
17.01.2021 10:22
Сообщение, записанное буквами 16-символьного алфавита, содержит 69 символов. Какое количество информации оно несет?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
Writeln('k=',ArrRandom(15,1,20).Println.Count(x->x>10))
end.
Тестовое решение
4 16 14 9 11 18 17 14 14 15 1 1 9 10 15
k=9
2. А вот так учат решать в школе...
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
var
a:array[1..15] of integer;
i,k:integer;
begin
Randomize;
k:=0;
for i:=1 to 15 do begin
a[i]:=Random(20)+1;
Write(a[i],' ');
if a[i]>10 then k:=k+1
end;
Writeln;
Writeln('k=',k)
end.
Тестовое решение:
18 15 7 6 3 3 10 6 6 15 2 16 16 2 12
k=6