В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Nazar0905
Nazar0905
14.02.2023 15:49 •  Информатика

Написать программу, которая, решает квадратное уравнение |ax+b|=cx+d. на вход вы получаете a,b,c,d. на выходе должно быть, либо 2 корня если таких 2, либо 1, либо надпись что корней нет

Ответ:
lolo105
lolo105
03.10.2020 07:35
Думаю тебе нужно ещё подождать 
0,0(0 оценок)
Ответ:
plahowajana
plahowajana
03.10.2020 07:35
Program rtr1;Uses crt;Var a,b,c,d,di,f,x1,x2:real;Begin Clrscr; Readln(a,b,c,d); f:=0; di:=sqr(2*a*b-2*c*d)-4*(a*a-c*c)*(b*b-d*d); if di>0 then  begin   x1:=((2*c*d-2*a*b)+sqrt(di))/(2*a*a-2*c*c);   x2:=((2*c*d-2*a*b)-sqrt(di))/(2*a*a-2*c*c);   if (abs(a*x1+b)=c*x1+d) then f:=f+1;   if (abs(a*x2+b)=c*x2+d) then f:=f+1;  end else if d=0 then              begin               x1:=(2*c*d-2*a*b)/(2*a);               if (abs(a*x1+b)=c*x1+d)then f:=f+1;             end             else writeln('Корней нет'); Writeln('Уравнение имеет ',f,' корней ');End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?