В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dashulyamikhay
dashulyamikhay
08.03.2023 15:53 •  Информатика

Решить на pasсal. во всех массив состоит из 10 элементов и задаётся из интервала от 1 до 99. 1.написать программу, которая выводит на экран все четные элементы массива и их количество. 2.написать программу, которая выводит на экран все двузначные элементы массива и их количество. 3.написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по индексу). написать программу, которая выводит на экран сначала все четные элементы, а потом нечетные (по значению). 5.написать программу, которая выводит на экран количество элементов оканчивающихся на 5.

Ответ:
Xomka03
Xomka03
13.08.2020 19:31
1. var a: array[1..10] of integer;
          i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  kol := 0;
  for i := 1 to 10 do
    if a[i] mod 2=0 then
    begin
      kol := kol + 1;
      write(a[i],' ');
    end;
  writeln;
  writeln(kol);
End.
2. var a: array[1..10] of integer;
    i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  kol := 0;
  for i := 1 to 10 do
    if a[i] > 9 then
    begin
      kol := kol + 1;
      write(a[i],' ');
    end;
  writeln;
  writeln(kol);
End.
3. var a: array[1..10] of integer;
    i: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  for i := 1 to 10 do
    if a[i] mod 2=0 then write(a[i],' ');
  for i := 1 to 10 do
    if a[i] mod 2=1 then write(a[i],' ');
End.
4. var a: array[1..10] of integer;
    i, r: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  i := 1;
  while i < 10 do
    if a[i+1] < a[i] then begin
      r := a[i+1];
      a[i+1] := a[i];
      a[i] := r;
      i := 1;
    end else i := i + 1;
  for i := 1 to 10 do
    if a[i] mod 2=0 then write(a[i],' ');
  for i := 1 to 10 do
    if a[i] mod 2=1 then write(a[i],' ');
End.
5. var a: array[1..10] of integer;
    i, kol: Integer;
Begin
  for i := 1 to 10 do read(a[i]);
  for i := 1 to 10 do
    if a[i] mod 10 = 5 then kol := kol + 1;
  writeln(kol);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?