В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Zmei0907
Zmei0907
27.11.2020 05:19 •  Информатика

Написать программу нахождения суммы нечётных цифр в натуральном числе. pascal

Ответ:
aniavetisa
aniavetisa
03.10.2020 07:34
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
  var n:=ReadInteger('n=');
  var s:=0;
  while n<>0 do begin
    var d:=n mod 10;
    if Odd(d) then s+=d;
    n:=n div 10
    end;
  Writeln('Сумма нечетных равна ',s)
end.

Тестовое решение:
n= 25325423
Сумма нечетных равна 16
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?