В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1298school
1298school
01.06.2020 14:15 •  Информатика

Написать программу на паскале дана строка символов .проверить есть ли в этой строке все буквы,входящие в слово "тигр"

Ответ:
elvira13131313
elvira13131313
22.09.2020 08:54
var i,n,k,z,x:integer;
s:string;
BEGIN
writeln(s);readln(s);
for i:=1 to length(s) do begin
if (s[i]='т') then n:=n+1;end;
for i:=1 to length(s) do begin
if (s[i]='и') then k:=k+1;end;
for i:=1 to length(s) do begin
if (s[i]='г') then x:=x+1;end;
for i:=1 to length(s) do begin
if (s[i]='р') then z:=z+1;end;
if ((n>0) and (k>0) and (x>0) and (z>0)) then writeln('есть все буквы')
else writeln('no');end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?