В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
roman19781975
roman19781975
08.11.2020 14:54 •  Информатика

Составьте программу в паскале. поиск максимального 3-х чисел. учесть случай, когда а=в=с (вывести сообщение "числа равны"). блок-схема обязательна.

Ответ:
hammyhjh
hammyhjh
03.10.2020 07:31
//Pascal ABC.NET v3.0 сборка 1111

//"Школьный" вариант, первая блок-схема

Var
 a,b,c:integer;
begin
 read(a,b,c);
 if (a=b) and (b=c) then writeln('=') else
  begin;
 if a>b then
  if a>c then writeln(a);
 if b>a then
  if b>c then writeln(b);
 if c>a then
   if c>b then writeln(c);
  end;
end.

//Вариант для любителей оккультизма, вторая блок-схема

begin
 var se:=ReadArrReal(3);
 if se.Sum()/se.Average()=se.Average() then writeln('=') else writeln(se.Max);
end. 

Пример ввода:
3
3
3
Пример вывода:
=
Составьте программу в паскале. поиск максимального 3-х чисел. учесть случай, когда а=в=с (вывести со
0,0(0 оценок)
Ответ:
xcp4
xcp4
03.10.2020 07:31
Var
  a:array [1..3] of real;
  max: real;
  i,check:integer;
begin
  writeln('Поиск максимального 3-х чисел');
  writeln('Введите значения 3-х чисел');
  for i:= 1 to 3 do
    readln(a[i]);
  max:=a[1];
  check:=1;
  for i:=2 to 3 do
  begin
    if a[i]>max then
      max:=a[i]
    else if a[i]=max then
      check:=check+1;
   end;
if check=3 then
  writeln('Все числа равны')
else   
  writeln('Max=',max)
end.

Составьте программу в паскале. поиск максимального 3-х чисел. учесть случай, когда а=в=с (вывести со
Составьте программу в паскале. поиск максимального 3-х чисел. учесть случай, когда а=в=с (вывести со
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?