Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
dmxboy
05.12.2021 04:50 •
Информатика
Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые
Ответ:
LadyDay
13.08.2020 19:30
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
var s:=ReadInteger('n=').ToString;
if (Pos(s[1],Copy(s,2,2))>0) or (s[2]=s[3])
then Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
end.
Тестовое решение:
n= 141
Есть одинаковые цифры
0,0
(0 оценок)
Популярные вопросы: Информатика
Sanyaaa12
26.10.2021 14:04
Перший табличний процесор одержав назву. Обери один варіантVisiCalcCalculonMicrosoft WordMicrosoft Excel...
markiza666
11.05.2022 03:05
Даны различные действительные числа x, y, z, d. Найти min(max(x, y), max(x, z), max(z, d)). Надо оформить в EXCEL...
1234555676
01.11.2020 11:11
Дана программа на языке Паскаль. Программа определения весовой категории в зависимости от веса спортсмена. Если вес спортсмена меньше 69, то «лёгкая категория» иначе «средняя...
Волк123111
06.03.2020 08:01
Мадинаға графикалық редакторда қайталанатын элементі бар ою жасау керек. Қайталанатын өрнегі бар ою жасау үшін орындалатын әрекеттерді дұрыс ретпен орналастыр....
асланбек13
08.11.2022 11:55
Сделайте Это я не понимаю как...
Kseniya000001
14.10.2022 14:24
Дан ряд распределения дискретной случайной величины. Найти х. Очень нужна...
zukhra9087
29.12.2021 03:23
Почему торфяные болота можно назвать летописной книгой?...
шунгит
07.12.2021 01:45
нужно ответить на все вопросы по английски минимум 2 предложение по английски 1. do you find your school information technology classes interesting? why? 2. how much time per...
Mашуня1111
24.02.2021 10:13
Укажи хімічну формулу бінарної сполуки. А- О²;Б- Н²СО³;В- NO²;Г- H²SO⁴...
2016mashamulalp0500j
08.08.2022 01:05
Причина превращения Арабского государства в империю...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var s:=ReadInteger('n=').ToString;
if (Pos(s[1],Copy(s,2,2))>0) or (s[2]=s[3])
then Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
end.
Тестовое решение:
n= 141
Есть одинаковые цифры