Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
lovivirus1234
18.02.2021 22:15 •
Информатика
Переставьте в массиве первые три и последние три элемента местами, не нарушая в каждой из троек порядка следования.
Ответ:
hgcfm
21.09.2020 23:29
Var
m : array[1..10] of Integer;
i,t : Integer;
Begin
For i:=1 to 10 do
Begin
m[i]:=i;
Write(m[i]:3);
end;
Writeln;
For i:=1 to 3 do
Begin
t:=m[i];
m[i]:=m[10-3+i];
m[10-3+i]:=t;
end;
For i:=1 to 10 do Write(m[i]:3);
Writeln;
end.
Результат:
1 2 3 4 5 6 7 8 9 10
8 9 10 4 5 6 7 1 2 3
0,0
(0 оценок)
Популярные вопросы: Информатика
впапорпорпрорп
09.05.2022 10:34
Сколько байт и бит в предложении сейчас буду выполнять...
Сергій2006SSS
30.04.2021 15:15
Дано описание массива: var a: array [1..57] of integer; здесь oписан массив a из целочисленных значений. при выполнении этого оператора в памяти компьютера будет выделено...
ЖекЖек
09.07.2020 09:09
Написать программу на языке Паскаль: Создать двумерный массив размерностью 3строки и 4 столбца...
ник5040
29.11.2022 10:44
Напишите последовательность команд, с которой можно переставить значения переменных a и b так, чтобы выполнялось условие...
nosorpg02
08.05.2021 22:39
Запиши математическое выражение (23+x)2 на языке Паскаль. (При записи ответа используй прописные буквы)....
ildarka34
13.03.2023 13:54
Как вы представляете использование 3 Д редакторов в своей жизни?...
лала123451
06.04.2023 01:21
Вкаком слове есть мягкие согласные? пилить,жить,ёжики,висеть,перелетать,чулочки...
nz010
06.04.2023 01:21
Рассказ о рейне (это река в германии) 1. данные ( куда втекает, в каких странах протекает и т.д.) 2. рейн в жизни германии и немцев. можно на . до 22: !...
lisafoxxxxxxxx
06.04.2023 01:21
Как происходили выборы консулов в риме?...
Вадим98913
06.04.2023 01:21
Какие особенности внешнего строения земноводных их жизни в воде , а какие на суше ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
m : array[1..10] of Integer;
i,t : Integer;
Begin
For i:=1 to 10 do
Begin
m[i]:=i;
Write(m[i]:3);
end;
Writeln;
For i:=1 to 3 do
Begin
t:=m[i];
m[i]:=m[10-3+i];
m[10-3+i]:=t;
end;
For i:=1 to 10 do Write(m[i]:3);
Writeln;
end.
Результат:
1 2 3 4 5 6 7 8 9 10
8 9 10 4 5 6 7 1 2 3