В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Составить программу определяющую, какая из букв «е» или «о» встречается в тексте чаще.

Ответ:
бомж23
бомж23
03.10.2020 07:04
#include "iostream"
#include "cstring"
using namespace std;
int main(){
char ch[10000];
cin.get(ch, 10000);
int count_o = 0;
int count_e = 0;
for(int i = 0; i < strlen(ch); i++){
if(ch[i] == 'о' || ch[i] == 'О')
count_o++;
if(ch[i] == 'е' || ch[i] == 'Е')
count_e++;
}
if(count_o > count_e)
cout << "Букв О больше";
else if(count_a == count_e)
cout << "Е и О равное количество";
else
cout << "Букв Е больше";
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?