В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
гоша210
гоша210
27.12.2020 05:06 •  Информатика

Составить программу на языке паскаль составить программу сокращения одномерного числового массива путем удаления ( всех элементов с нулевыми значениями . дополнительный массив использовать не разрешается ) можети поясните словами что делает программа

Ответ:
Андрей20531
Андрей20531
27.05.2020 18:23

var

  a : array of integer;

  n, i, last : integer;

begin

  read (n);

  setlength (a, n);

  for i := 0 to n - 1 do

    read (a[i]);

  last := 0;

  for i := 0 to n - 1 do

    if a[i] <> 0 then

    begin

      a[last] := a[i];

      inc (last);

    end;

  setlength (a, last);

  for i := 0 to last - 1 do

    write (a[i], ' ');

end.

 

Суть такова. Имеем динамический массив. Считали массив, так как динамический, то от нуля все. Установили последнюю свободную ячейку 0. Идем по массиву и ищем ненулевое значение. Как только нашли, пишем его в свободную ячейку и увеличиваем занчение свободной ячейки на 1. При этом наши данные не затираются. После окончания всех операций в last лежит длина массива.

Статитечкий массив. 

var

  a : array [1..100] of integer;

  n, i, last : integer;

begin

  read (n);

  for i := 1 to n do

    read (a[i]);

  last := 1;

  for i := 1 to n do

    if a[i] <> 0 then

    begin

      a[last] := a[i];

      inc (last);

    end;

  dec (last);

  for i := 1 to last do

    write (a[i], ' ');

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?