В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
liliannaklochko
liliannaklochko
03.01.2020 08:17 •  Информатика

Написать программу подсчитывающую вол-во цифр в заданном числе.

Ответ:
zebra60
zebra60
21.09.2020 22:16
Var 
i,a:integer; 
ch:set of char; 
n:string;
Begin 
Write('Введите число '); 
Readln(n); 
ch:=['0'..'9']; 
for i:= 1 to length(n) do   
 if n[i] in ch then a:=a+1; 
case a of 
1:Write('В числе ',a,' цифра'); 
2..4:Write('В числе ',a,' цифры') 
else Write('В числе ',a,' цифр'); 
End;
End.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?