В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zukhra9087
zukhra9087
05.05.2021 10:58 •  Информатика

Написать программу на c#! даны координаты точки а(х1,у1). определить, принадлежит ли эта точка какой-нибудь оси координат. если да, то какой.

Ответ:
NBAH123
NBAH123
03.10.2020 06:35
Using System;

class Program
{
    static void Main()
    {
        for(var x=-2;x<=2;x++){
            for(var y=-2;y<=2;y++){
                IsPointOnAxis(x, y);
            }
        }
        Console.ReadKey();
    }

    static void IsPointOnAxis(int x, int y){
        Console.WriteLine("Point  = {0}; {1}", x, y);
        if (x*y != 0){
            Console.WriteLine("Point not on axis");
            return;
        }

        if (x == 0){
            Console.WriteLine("Point is on axis Ox");
        }else if (y == 0){
            Console.WriteLine("Point is on axis Oy");
        }
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?