В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
qwertyzored
qwertyzored
21.05.2023 06:21 •  Информатика

Напишите программу на языке паскаль которая выводит порядковый номер минимального элемента в двухмерном массиве

Ответ:
KeyTyan12345
KeyTyan12345
25.08.2020 09:50
//Pascal ABC.NET v3.0 сборка 1111

Const
 n=10;

Var
 ma:array[1..n,1..n] of integer;
 min,mini,minj,i,j:integer;
begin
min:=2147483647;
 randomize;
  writeln('Matrix:');
   for i:=1 to n do
   begin;
   writeln;
    for j:=1 to n do
     begin;
      ma[i,j]:=random(300);
      write(ma[i,j]:4);
      if min>ma[i,j] then
       begin;
        min:=ma[i,j];
        mini:=i;
        minj:=j;
       end;
     end;
   end;
 writeln;
 write('Строка:',mini,' столбец:',minj);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?