В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
madamnowiczkai
madamnowiczkai
15.11.2021 13:32 •  Информатика

Цикл с предусловием составить программу нахождения частного q и остатка от деления r целого числа х на целое число у, не используя операцию деления.

Ответ:
kristinaFro
kristinaFro
15.09.2020 17:21
Var
 x, y, q, r: integer;
begin
 read(x,y);
 r := x;
 q := 0;
 while r >= y do
   begin
   r := r - y;
   q := q + 1
   end;
 write(q,' ',r)
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?