Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
гуля5182
15.03.2023 08:40 •
Информатика
18 ! составьте программу, используя цикл while do. найти сумму чисел 2,4,6,.
Ответ:
простониккакойтотам
03.10.2020 06:26
Program pr;
uses crt;
Var sum,i:integer;
Begin
i:=2;
sum:=0;
While i<=20 do
Begin
sum:=sum+i;
i:=i+2;
end;
Writeln('sum = ', sum);
readln();
end.
0,0
(0 оценок)
Ответ:
chunya20041
03.10.2020 06:26
Можно вообще без циклов:
Var a,b : Integer;
Begin
a:=2; b:=20;
Writeln((b+a)*((b-a) div 2+1) div 2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
levickai200
19.01.2020 04:41
Впрограмме описан одномерный целочисленный массив с индексами от 0 до 10. в ниже фрагменте программы массив сначала заполняется, а потом изменяется: for i: =0 to 10 do a[10-i]: = i...
aleksandrovauli
19.01.2020 04:41
Как сделать видео задом на перёд в camtasia studio 8...
Strummer
19.01.2020 04:41
Составить на алгометрическом языке программу для сложения всех чётных чисел от 0 до 200. ( т.е. идёт алгорим должен выглядеть так: алг нач дальше дописать)...
юстина6
01.11.2021 19:12
Нужна тема для сайта. два-три варианта. 20 !...
polinayotuber
03.05.2022 02:13
C# с клавиатуры вводится последовательность символов, заканчивающихся на $, строка должна иметь не более 50 символов. подчеркнуть все слова, заканчивающиеся на букву а (подчеркивание:...
mariyshak57
03.05.2022 02:13
Дан класс a, в котором определена перегрузка операции сложения. c++ объекты класса a могут складываться друг с другом и получать в результате значение типа short int. закончите прототип...
irarenkas
14.04.2021 02:29
Сгенерировать массив и n различных случайных чисел. найти сумму ее членов расположенных между максимальным и минимальным значениями (в сумму включить и оба этих числа) через динамический...
СуРиКан200606
10.12.2021 02:30
Nнечетных чисел нужно вывести на экран n наименьших натуральных нечетных чисел. input со стандартного устройства ввода вводится 1 натуральное число – n (1 ≤ n ≤ 300) output нужно выдать...
Brot2007
16.09.2021 14:58
Каков энергетический эффект гликолиза?...
obizyana88
03.06.2020 12:36
Проанализировать информацию: «Чтобы институт управления по результатам заработал, необходима мобилизация важнейших социальных групп и институциональных структур общества, в том числе...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
Var sum,i:integer;
Begin
i:=2;
sum:=0;
While i<=20 do
Begin
sum:=sum+i;
i:=i+2;
end;
Writeln('sum = ', sum);
readln();
end.
Var a,b : Integer;
Begin
a:=2; b:=20;
Writeln((b+a)*((b-a) div 2+1) div 2);
end.