В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
elenasamsonova1
elenasamsonova1
31.05.2020 07:24 •  Информатика

Написать программу на языке паскаль для нахождения площади треугольника по трем сторонам

Ответ:
Kiki137
Kiki137
21.09.2020 15:50
Площадь треугольника по 3м сторонам вычисляется по формуле Герона: \sqrt{p*(p-a)*(p-b)*(p-c)}, где p-полупериметр.
Тогда:

var a,b,c,p:real;
begin
  writeln('Введи длины сторон a, b и c');
  readln(a,b,c);
  p:=(a+b+c)/2;
  writeln('Площадь этого треугольника = ', sqrt(p*(p-a)*(p-b)*(p-c)));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?