В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SomikBOOM
SomikBOOM
04.02.2021 08:59 •  Информатика

Составить программу в pascal. 3. пусть дано 100 вещественных чисел, которые вводятся по одному. вычисли¬те среднее арифметическое положительных и среднее арифметическое от¬рицательных чисел. 4. напечатать таблицу соответствия между весом в фунтах и весом в кг для значений от 1 до 10 фунтов с шагом 0,5 фунта. формула перевода: 1 фунт = 400 г. 5. составьте таблицу значений функции y = 5x2 – 2x + 1 на отрезке [-5; 5] с шагом 2.

Ответ:
dia49724zyf
dia49724zyf
07.08.2020 08:20
1)
   var
 a:array[1..100]of real;
 n,p,q,q1:real;
 i:integer;
   begin
    for i:=1 to 100 do
     begin
      read(a[i]);
      if a[i]>=0 then
       begin
        p:=p+a[i];
        q:=q+1;
       end;
      if a[i]<0 then
      begin
       n:=n+a[i];
       q1:=q1+1;
      end;
    end;
   writeln('positive:',p/q);
   writeln('negative:',n/q1);
 end.

2)
      uses crt;
var
n:real;
i:integer;
 begin
 n:=0.5;
 write('  Pounds','       Kg');
 writeln;
   for i:=1 to 20 do
    begin
    write ('    ',n,'       ', n*0.4);
    n:=n+0.5;
    writeln;
    end;
  
 end.

3)
  uses crt;
var
x:integer;
 begin
  write(' x','        y');
  writeln;
   for x:=-5 to 5 do
   begin
      write(x,'       ');
      write(5*(x*x)-(2*x)+1);
      writeln;
   end;
   end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?