В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

15 ! нужно составить программу в паскаль. если сумма различных целых чисел х, у, z меньше 30, то заменить меньшее из у и х суммой двух других. в противном случае увеличить все числа на 10

Ответ:
NoraDun
NoraDun
03.10.2020 05:56
Var x,y,z:integer;
begin
write('x='); readln(x);
write('y='); readln(y);
write('z='); readln(z);
if x+y+x<30
  then  if x<y then x:=x+y else y:=x+y
  else begin x:=x+10; y:=y+10; z:=z+10 end;
writeln('x=',x,'  y=',y,'  z=',z);
end.

Пример:
x=7
y=12
z=9
x=19  y=12  z=9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?