В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Подскажите . (для программы кумир и паскаль) написать программу в процессе выполнения которой, получить случайное трехзначное число и вывести через запятую его отдельные цифры. пример: получено число 123. его цифры 1, 2, 3. примечание: используйте функцию irand, операции div и mod.

Ответ:
aleksBRO
aleksBRO
03.10.2020 05:53
Решение на паскале:
//PascalABC.NET
//NaaMan
var
    n,i:integer;
    r,c,s:string;
begin
    randomize;
    n:=random(100,999);
    writeln('Сгенерированное число > ', n);
    s:=','; r:='.'; c:='';
    for i:=1 to 3 do begin
        if (i=3) then s:='';
        str(n mod 10,c);
        r:=concat(s,c,r);
        n:=n div 10;
    end;
    writeln(r)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?