В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mrpekhterov
mrpekhterov
22.04.2020 09:20 •  Информатика

:вывести числа до n, которые делятся на сумму своих цифр. написать программу на языке си

Ответ:
bogdankavolev9
bogdankavolev9
19.08.2020 11:53
// Возможно, это работает

#include<stdio.h>

int main()
{
 int x,s,l,n;
 scanf("%d", &n);
 do{
 s = 0;   
 for(x = 1; x <= n; x++)
   {
   s += 1;
   l = 10;
   while(x % l == 0){s -= 9; l *= 10;};
   if(x % s == 0) printf("%d ",x);    
   };
 printf("\n");
 scanf("%d", &n);
} while(n > 0);       
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?