В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
стланка
стланка
28.04.2020 08:25 •  Информатика

Составить программу для вычисления a - сумма отрицательных элементов массива; b – количество четных элементов массива; c - номер первого положительного элемента массива. полученные значения элементов а,b,c,f вывести на печать. f: =c+((a+b)/(10-c+

Ответ:
кристина2155
кристина2155
03.10.2020 05:51
Const n=20;
var x,y : array[1..n] of integer;
   i,a,b,c : integer; f:real;
begin
Randomize;
 writeln('Исходный массив:');
for i:=1 to n do
 begin
  x[i]:=random(101)-50;
  write(x[i],' ');
 end;
 writeln;
a:=0; b:=0; c:=0;
for i:=1 to n do
 begin
 if x[i]<0 then a:=a+x[i];
 if x[i] mod 2 = 0 then b:=b+1;
 if (c=0)and(x[i]>0) then c:=i;
 end;
writeln('A=',a,'  B=',b,'  C=',c);
f:=c+((a+b)/(10-c+a));
writeln('F=',f:5:2);
end.

Пример:
Исходный массив:
10 -37 1 31 -22 45 3 32 -2 48 -19 -48 39 22 -39 -29 -49 8 -16 22
 A=-261 B=10 C=1
F= 2.00
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?