В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
danil200804
danil200804
21.02.2023 20:41 •  Информатика

Напишите программу. 1). дан радиус шара. найти его объём. 2). даны стороны треугольника: a,b,c. вычислить косинусы углов по теореме косинусов. 3). опредедить, сколько полных часов и полных минут к этому моменту от начала суток. 4). три сопротивления r1, r2 и r3 соединены параллельно. найти сопротивление соединения r0. идёт k-ая

Ответ:
Крад
Крад
07.09.2020 13:11
1.
var
R,V: Real;
begin
ReadLn(R);
V:= (4/3)*pi*sqr(R)*R;
WriteLn(V);
ReadLn;
end.
2.
var
 a, b, c, CAB, CBA, ACB: Real;  
begin
writeln('vvedite storonu a'); readln (a);
writeln('vvedite storonu b'); readln (b);
writeln('vvedite storonu c'); readln (c);
CAB:=(sqr(c)-sqr(a)-sqr(b))/(-2*a*b);
CBA:=(sqr(a)-sqr(b)-sqr(c))/(-2*b*c);
ACB:=(sqr(b)-sqr(a)-sqr(c))/(-2*a*c);
writeln('ugol CAB =', CAB:3:2 );
writeln('ugol = CBA = ', CBA:3:2 );
writeln('ugol = ACB = ', ACB:3:2 );
readln;
end.
3.
//uses crt;
var
k: Integer; // Идёт k-ая секунда
begin
ReadLn(k);
WriteLn('Часов:', k div 3600);
While k>=3600 do k:= k - 3600;
WriteLn('Минут:', k div 60);
end.
4.
var
R1, R2, R3, R0: Real;
begin
WriteLn('Vvedite R1 ='); ReadLn(R1);
WriteLn('Vvedite R2 ='); ReadLn(R2);
WriteLn('Vvedite R3 ='); ReadLn(R3);
R0:=1/(1/R1+1/R2+1/R3);
WriteLn('Soprotivlenie = ', R0);
ReadLn;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?