В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lalalol1
lalalol1
08.04.2023 12:04 •  Информатика

Составить программу выводящую на экран все делители на число х.(число х вводится с клавиатуры)

Ответ:
visskikross
visskikross
23.05.2020 18:29

program ml;
uses crt;
var x,i:integer;
    w,l:real;
begin
clrscr;
readln(x);
L:=x;
for i:=1 to x do                         begin
w:=w+1;
l:=x/w;
if frac(l) = 0 then writeln(l:2:0);
                                                end;
readkey;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?