Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
катя10467743
30.05.2023 10:40 •
Информатика
Написать код программы на языке паскаль для вычисления значений функции типа y=sqr(l/x) напишите подпрограмму обработки ошибок.
Ответ:
YakovlevaJulia2004
20.09.2020 21:53
Var y,x,l:real;
begin
writeln('Введите значение l и x соотвественно');
read(l,x);
if x=0 then writeln('x не может быть равен нулю, так как дробь нельзя делить на ноль')
else begin
y:=sqr(l/x);
writeln(y);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Belka1211
18.03.2020 21:50
Команда int() используется * чтобы ввести данные с клавиатурычтобы выводить ответ на экранчтобы ограничить вводимую информацию с клавиатурычтобы выводить данные...
klimkravcnko
18.05.2023 06:53
Как получить данные от пользователя? * Использовать метод read() Использовать метод cin()Использовать метод input()Использовать метод readLine()Использовать метод get()...
77Stranik77
17.11.2022 16:42
Установите соответствие *.bmp *.txt...
zlataaug
26.08.2020 16:39
Выберите оптимальное имя файла для реферата по естествознанию о природных явлениях: • Документ. • Естествознание. • Природные явления....
kristinakomaro5
02.10.2021 23:48
Вывести на экран все значения функции y = 5 ∗ x + x 2 , при x =50, 49, 48, ..., 40...
yuniman
21.01.2022 19:19
Мария выбрала инструменты и начала рисовать правой кнопкой мыши что нарисует мария...
krop40
08.01.2022 01:05
Уровень B. Напишите программу, которая получает день и номер месяца и определяет дату следующего дня. Считайте, что год невисокосный (365 дней). Пример: Введите день и месяц: 25...
ама34
06.08.2022 16:43
Скажите что нужно делать? Не получается зайти на сервер ...
345153
03.06.2020 10:23
1. Напишите определение условного оператора (1б). 2. And, or и not - это ... операторы (1б). 3. Алгоритмическая запись условного оператора имеет 2 формы записи. Какие?(1б) 4. Есть...
dhdhhd55
08.09.2021 19:49
Практическая работа Тема: Кодирование графической информации. Цель: Развить навык в работе с изображениями, их сохранении и изменении размера. Ход работы Задание 1. 1. На рабочем...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
writeln('Введите значение l и x соотвественно');
read(l,x);
if x=0 then writeln('x не может быть равен нулю, так как дробь нельзя делить на ноль')
else begin
y:=sqr(l/x);
writeln(y);
end;
end.