В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
gurulezz1257
gurulezz1257
20.10.2020 09:02 •  Информатика

Написать программу в паскале найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр.

Ответ:
luska059
luska059
31.07.2020 13:59
Function Check(k : Longint) : Boolean;
Var j : Byte;
Begin
  Check:=True;
  j:=k;
  While j>0 do
  Begin
    If (j mod 10 = 0) or (k mod (j mod 10)<>0) then Check:=False;
    j:=j div 10;
  end;
end;

Var
  n,i : Longint;
Begin
  Readln(n);
  For i:=1 to n do
    If Check(i) then Writeln(i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?