В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу на паскале абс дано трехзначное число. найдите его палиндром и произведение палиндрома и данного числа. числовой палиндром — это натуральное число, которое читается слева направо и справа налево одинаково. иначе говоря, отличается симметрией записи (расположения цифр), причём число знаков может быть как чётным, так и нечётным. например, 165 его палиндром 561.

Ответ:
RumikoZun
RumikoZun
30.08.2020 18:15
Program palidron;

var
   a, b, c, x, d: integer;

begin
      writeln('Число:');
       readln(a);
       b:= a mod 10;
       c:= (( a div 10) mod 10);
       x:= (( a div 10) div 10);
       d:= 100*b+10*c+x;
       writeln('Палиндром: ',b,c,x);
       writeln('Произведение числа и палиндрома: ',d*a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?