В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Koshmmarik
Koshmmarik
01.05.2022 21:43 •  Информатика

Составьте программу для вычисления косинусов углов треугольника со сторонами a, b, c. указание. примените теорему косинусов: c2=a2 + b2 -2ab * cos α

Ответ:
Nymeria
Nymeria
07.09.2020 11:45
Var a,b,c,cosa, cosb, cosc:real; 
begin 
writeln('Введите стороны треугольника АВС'); 
read(a,b,c); 
cosa:=(sqr(b)+sqr(c)-sqr(a))/(2*b*c); 
cosb:=(sqr(c)+sqr(a)-sqr(b))/(2*c*a); 
cosc:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b); 
writeln('Косинус угла А = ', cosa, ' Косинус угла В =', cosb,' Косинус угла C =', cosc); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?