В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
denisprokopev
denisprokopev
11.07.2020 22:30 •  Информатика

Буду признателен. код на c++: написать программу, которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей. подсчитать количество слов в строке.

Ответ:
eleonora1306200
eleonora1306200
15.09.2020 14:48
#include <iostream>
#include <sstream>
using namespace std;

 int main(){
   string str;
   getline(cin,str); //вводим поток в строку
   stringstream ss(str); //вводим строку в поток, при этом пробел делит слова на отдельные элементы
   int i(0); //счётчик
   while(ss>>str) //пока можно выводить элементы(слова)
    i++;
   cout << i;
   cin.get();
   cin.get();
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?