Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Hexihexi
01.09.2022 20:42 •
Информатика
Написать программу,. подсчитать сумму ряда -1-2+3+4-5-6+7++n n-вводится пользователем (цикл со счетчиком (for i: =1 to n do))
Ответ:
MrDackes
03.10.2020 03:38
// PascalABC.NET 3.0, сборка 1138
var
i,n,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do
if ((i mod 4)=1) or ((i mod 4)=2) then s:=s-i else s:=s+i;
Writeln('Сумма ряда равна ',s)
end.
Тестовое решение:
n=13
Сумма ряда равна -1
0,0
(0 оценок)
Популярные вопросы: Информатика
Moldir94
20.08.2020 16:25
Дано натуральное число. Напишите программу, которая вычисляет: количество цифр 3 в нем; сколько раз в нем встречается последняя цифра; количество четных цифр; сумму его цифр,...
ficon263
30.05.2023 03:40
Программа на C# Используя операции: / (целочисленное деление) % (деление по модулю), Определить сумму цифр 3-х значного числа, введённого с клавиатуры. Ваша задача представить...
zhenyadobr
06.10.2021 20:23
Задания №2 Подчеркните одной линией то, что делать МОЖНО, и двумя линиями то, чего делать НЕЛЬЗЯ в тексте ниже: Входить в кабинет информатики без разрешения учителя. Заходить...
kristaile
23.07.2021 18:35
3D-модели объектов. Урок 1 Изучи параметры материалов и модификатора «Bevel» и определи цвет, который применен к углам куба....
Кrистинkа2006
16.01.2023 13:26
Сложить числа 110111 (двоич) и 10011 (двоич) 1010101 (двоич) и 10011 (двоич) сложить 11110100 двоич и 271 (восьмиричн.) результат представить в восьмиричной сложить числа...
mita421132
22.02.2022 21:16
11. определить значение переменной s после выполнения следующих команд. … s: =3; i: =2; пока i =17 выполнять начало цикла s: =s+i; i: =i+2; конец цикла s: =s+8; … 12. дано...
Haranmeu
22.02.2022 21:16
Мне нужен доклад по информатике на тему: приложение общего назначения. .к концу четверти нужно оценки зарабатывать,а доклад мне не найти . заранее ....
pollylu12
22.02.2022 21:16
Графичиский файл. величина : значение: большой файл.величина: значение:...
popovaviktoriy3
28.05.2022 08:58
Нужен доклад на тему : приложение общего назначение.заранее ....
18larina18
23.10.2020 04:00
Выберете числа которые являются отрицательными +9-1/90,5618-19-20...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
i,n,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do
if ((i mod 4)=1) or ((i mod 4)=2) then s:=s-i else s:=s+i;
Writeln('Сумма ряда равна ',s)
end.
Тестовое решение:
n=13
Сумма ряда равна -1