Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Умницка1
06.11.2020 10:06 •
Информатика
Составить программу и блок-схему для решения . решение каждой сопроводить пояснительной запиской с описанием используемых в конструкций языка си. a[n] найти среднее элементов массива а . ai > 0; n=10
Ответ:
Аноним20021304
03.10.2020 03:36
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Миша20072007
09.06.2023 16:18
При каких моментах информация в ПК будет измеряться в килобайтах...
statarincev2019
03.02.2020 19:18
Составь по выражению и реши её : 100-(25+15); . (20+20)+50=?...
Ren484
03.02.2020 19:18
Як вставити в текст символи, яких немає на клавіатурі. записати алгоритм дій....
Uprava78
03.02.2020 19:18
Наташа живет в трехетажном доме на последнем этаже.удастся ли ей принять душ,если насос ,установленный на полу первого этажа 2,8 м,а лейка душа расположена на высоте 2м от...
Дмитрий1425
03.02.2020 19:18
Основание равнобедренного треугольника в два раза короче боковой стороны, а периметр равен 75см. найдите стороны треугольника....
Раммроль
03.02.2020 19:18
Дана арифметическая прогрессия, разность которой равна 1,1, а1=-7. найдите а14...
mafa4334
03.02.2020 19:18
Из квадрата со стороной 8 см вырезан прямоугольник со сторонами 3 см и 2 см. найдите площадь оставшейся части . ответ дайте в см2....
Maguire
03.02.2020 19:18
Краствору содержащему 17 г гидроксида калия применили раствор соляной кислоты .определить массу образовавшейся соли?...
LavaGirl14
03.02.2020 19:18
9408-1628: 4(9*397-2753)*4 решите столбиком !...
Fkrfi134F
03.02.2020 19:18
Найдите угол в, если в треугольнике авс угол а= 30 градусов, ас=2 см, вс=√2 см....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}