В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sofia20091
Sofia20091
17.05.2023 17:26 •  Информатика

Напишите программу создания n-символьной последовательности, состоящей из совокупности 3 символов с использованием строк (например '0', '1', '2' или 'a', 'b', 'c') в которой нет двух смежных идентичных подпоследовательностей. для n=11 последовательность может иметь вид "01020120210".

Ответ:
alinkamomot2004
alinkamomot2004
03.10.2020 03:34
#include <iostream>
#include <string>
#include <time.h>
using namespace std;

void main()
 {
srand(time(NULL));
int n,k=0,k1=4;
cin >> n;                         //вводишь количество символов
string *s=new string [n];
for (int i = 0;i < n;++i)
{
while (k == k1)
{
k = rand() % 3;
}
switch (k)
{
case 0:s[i] = '0';cout << s[i];break;
case 1:s[i] ='1';cout << s[i];break;    //вместо 0,1,2 пишешь свой алфавит .
case 2:s[i] ='2';cout << s[i];break;
}
k1 = k;
}
system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?