В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katelove8
katelove8
07.06.2021 07:25 •  Информатика

Как на pascal abc написать программу, которая будет считать сумму цифр числа, введенного с клавиатуры? количество цифр в числе неизвестно! число целое. желательно с объяснениями (вне программы). заранее ! p.s. я 15 ! !

Ответ:
stoyanovadsДарья
stoyanovadsДарья
30.08.2020 17:13
Program LOL2016;
var n,s,r:integer;
begin
readln(n);
s:=0;
while(n <> 0) do begin
r:=n mod 10;
s:=s+r;
n:=n div 10;
end;
writeln(s);
end.

если что то не понятно просто спроси и я обьясню  :)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?