В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ераврлга
ераврлга
07.06.2021 07:25 •  Информатика

Как на pascal abc написать программу, которая будет считать сумму цифр в числе, введенного с клавиатуры? количество цифр в числе не известно! число целочисленное! желательно с объяснениями ( вне программы ). заранее !

Ответ:
jesussoul
jesussoul
20.09.2020 09:16
Var a,b,c,d:integer;
begin
writeln('введите число'); //запрос числа
readln(a);
d:=a;                 //это для красоты
while (a<>0) do begin //пока мы не дойдём до последней цифры в числе делать следующее
  b:=a mod 10;        //берём последнюю цифру числа 
  c:=c+b;             //находим сумму цифр
  a:=a div 10;        //убираем из данного числа последнюю цифру
  end;
 writeln('сумма цифр числа ',d,' = ',c); // вывод результата
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?