В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
aljoona99
aljoona99
10.03.2020 10:15 •  Информатика

Найти сумму и произведение всех четных трех значных чисел. составить программу и алгоритм

Ответ:
Azhar1605
Azhar1605
20.09.2020 06:46
//Решение с использованием длинной арифметики
var i, j, sum, len, rem: integer;
    mult: array[1..1205] of integer;
begin
  len := 1;
  mult[1] := 1;
  i := 100;
  while i < 1000 do
  begin
    for j := 1 to len do
    begin
      rem := mult[j] * i + rem;
      mult[j] := rem mod 10;
      rem := rem div 10;
    end;
    while rem > 0 do
    begin
      inc(len);
      mult[len] := rem mod 10;
      rem := rem div 10;
    end;
    sum := sum + i;
    i := i + 2;
  end;
  writeln('Сумма: ', sum);
  write('Произведение: ');
  for i := len downto 1 do write(mult[i]);
  writeln;
end.

Результат работы программы:
Сумма: 247050
Произведение: 11663575674444359823002008139390746528142707402328361705647495301216245827892256323421573853031635648105175857107321864360366071385039128549679496343675509640183219826717346573458260381851930244150425562315833417515264123698581740276921937117732298873364203269398167251131992557619396626253824845619285980851485012131859200089180731617159967796785692496658820266554970195579987101761437467345295469560091019643416890744175485355715583034412689664621367823158491721734017238669568797130683826947437814864890599291484009747561514288528353178159298856645624289518581586947168677504742711452824976368290519747367284033226821443792754573564848344600041433089899538479032717299413920051538113896509134682791976736868238046387230383008696853107977931851651379555533347652931008271572588724198961970056163028633888796670948358527288343719100865852117339478785474064397937004993302565523495403857150309972891503340949896943795594807214141508464167055846685872109706922589562538698747726222566785521882450614299594376824656706451033378744188256788426310583732611392640652066952551824890922829689995132928000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?