В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nekit2409
nekit2409
29.10.2022 07:09 •  Информатика

Составить программу. вывести с клавиатуры целое число,и определить,есть ли в нем повторяющиеся цифры.программа должна вывести"да" или "нет". заранее .

Ответ:
nastyushakulik
nastyushakulik
20.09.2020 06:46
Uses crt;
var s:string;
i:integer;
l:boolean;   
m:set of char;
begin clrscr;
write('Введите число :');
readln(s); l:=false;
for i:=1 to length(s) do begin 
if  (m<>m-[s[i]]) then l:=true;
m:=m+[s[i]];
end;
if l then Writeln('Да')     
else Writeln('Нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?