В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zevs34
zevs34
14.06.2022 23:08 •  Информатика

Дан одномерный массив целых чисел, состоящий из 20 ячеек, заполненный случайными числами из промежутка [-9,9]. найти количество ячеек, с нечетными номерами, которые содержат число --5. напишите программу со всеми объяснениями !

Ответ:
guseva2yul
guseva2yul
03.10.2020 02:50
var
a:array[1..20]of integer;
i,n,c:integer;
begin
  for i:=1 to 20 do
  begin
   a[i]:=random(19)-9;
   write(a[i],' ');
   if i mod 2 =1 then
    if a[i]=-5 then
     c:=c+1;
  end;
  writeln;
  writeln(c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?