В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nhxjjxjx
nhxjjxjx
20.10.2020 16:42 •  Информатика

Составьте программу, которая заполняет массив b [1..15] случайными целыми числами в диапазоне от 1 до 20 и выводит все тройки элементов, строго по возрастанию. (pascal abc).

Ответ:
fonato
fonato
03.10.2020 02:48
Program CrazyCoder;
var ar:array[1..15] of integer;
i:integer;
begin;
var i1:=1;
writeln('Тройки элемента масива');
while i1<=15 do
begin
var ar1:=ArrRandomInteger(4,1,20);
sort(ar1);
ar[i1]:=ar1[1];
ar[i1+1]:=ar1[2];
ar[i1+2]:=ar1[3];
writeln(ar1[1]:4,ar1[2]:4,ar1[3]:4);
i1:=i1+3;
end;
writeln('Масив:');
for i:=1 to 15 do
write(ar[i]:4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?