В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ровно63
ровно63
19.11.2020 17:10 •  Информатика

Составьте программу нахождения суммы положительных значений массива.дан массив состоящий из 15 элементов.значение массива произвольные числа.

Ответ:
kolya1pokachalov
kolya1pokachalov
03.10.2020 02:48
Const
nmax=5;(любое число можешь поставить)
type
mas = array [1..nmax] of integer;

var
A:mas;
sum,n:integer;

begin
readln(n);
sum:=0;
for i:=1 to n do
 if  (A[i] > 0) then sum:=sum+A[i];

writeln('Summa=',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?