В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
помоги1361
помоги1361
24.03.2023 16:52 •  Информатика

Написать программу определения стоимости разговора по телефону с учетом скидки 20% представляемой по субботам и воскресениям.

Ответ:
LastGirlOnEarth
LastGirlOnEarth
18.09.2020 21:26
Var st:real;
    mn:integer;
    d:1..7;
begin
write('Введите стоимость 1 минуты в рублях st=');
readln(st);
write('Введите продолжительность разговора в минутах mn=');
readln(mn);
repeat
write('Введите номер дня недели d=');
readln(d);
until d in [1..7];
case d of
1..5:st:=st*mn;
else st:=st*mn*0.8;
end;
write('Стоимость разговора=',st:0:2);
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?