Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
progames2002
23.09.2020 09:25 •
Информатика
Решить в паскале нужно : дан одномерный массив найти сумму с четными индоксами
Ответ:
аноним12345567808
03.10.2020 02:43
Const n=10;
var a:array[1..n] of integer; i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=random(20);
write(a[i]:4);
end;
writeln;
s:=0;
for i:=1 to n div 2 do s:=s+a[2*i];
writeln('s=',s);
end.
Пример:
18 16 19 17 0 2 8 4 19 18
s=57
0,0
(0 оценок)
Популярные вопросы: Информатика
darina224
22.10.2021 16:54
Даны три числа найти наибольшее из них используя If, elif, else python...
Qwertysiq
04.03.2020 09:28
построить блок-схему и написать программу на ЯП Паскаль для решения следующих задач; а) Дано трехзначное число Х. Найти сумму цифр этого числа. б) Умножить последнюю...
daniilzagora
30.05.2020 12:03
Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от -1000 до 1000. Допишите на алгоритмическом языке программу, которая находит и выводит...
КривенкоЖеня
21.06.2022 10:36
JavaScript. Что выйдет, если вызов Say( Вася ); стоит в самом начале, в первой строке следующего кода:say ( Вася ); // Не будет ли ошибки? var phrase = Привет ;function...
vladishe1
13.09.2020 08:11
Написать метод, возвращающий наибольшее из двух чисел. Входные параметры метода – два целых числа. Протестировать метод.C#...
Каала
02.09.2021 17:38
надо! Буду очень Вам благодарен...
Moontrick
30.12.2021 17:45
Написать метод вычисления факториала числа, результат вычислений передавать в выходном параметре. Если метод отработал успешно, то вернуть значение true; если в процессе...
AnyRam
17.09.2021 03:49
Петя посылает Ване числовые коды от 0 до 255. Однако, эти коды особо важны — их могут перехватить, поэтому ребята договорились их шифровать. Алгоритм шифрования состоит...
Аркадий2018
13.05.2022 00:43
Написать метод, который меняет местами значения двух передаваемых параметров. Параметры передавать по ссылке. Протестировать метод.C#...
MI743
24.08.2021 18:46
Задача ниже, в решении у меня получается 350. Но правильный ответ 400, что не так ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:array[1..n] of integer; i,s:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=random(20);
write(a[i]:4);
end;
writeln;
s:=0;
for i:=1 to n div 2 do s:=s+a[2*i];
writeln('s=',s);
end.
Пример:
18 16 19 17 0 2 8 4 19 18
s=57