В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
DrNick
DrNick
28.04.2020 09:58 •  Информатика

Написать программу в паскаль. задано количество строк и столбцов матрицы и действительные значения ее элементов. сформировать и вывести транспонированную матрицу.

Ответ:
remizowanikaggr
remizowanikaggr
03.10.2020 02:25
Const
e=10000;
var
a:array[1..e,1..e] of real;
i,j,n,m:integer;
k:real;
begin
readln(n,m);
for i:=1 to n do
  for j:=1 to m do
  read(a[i,j]);
for i:=1 to n do 
for j:=i+1 to m do   
begin     
k:=a[i,j];     
a[i,j]:=a[j,i];     
a[j,i]:=k;   
end;   
for i:=1 to m do   
begin     
for j:=1 to n do 
write(a[i,j],' '); 
writeln; 
end; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?