В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sun54
sun54
14.11.2022 18:09 •  Информатика

Составьте программу, которая заполняет массив s [1..15] случайными целыми числами в диапазоне от -15 до 5 и находит количество элементов кратных 3.

Ответ:
Тётко
Тётко
15.09.2020 13:47
Var
a:array [1..30] of integer;  // тут можешь регулировать количество чисел
i,k,n:integer;
begin
k:=0;
writeln('введите количество чисел от 1 до 30');
read(n);
randomize;
for i:=1 to n do begin
a[i]:=random(16)-5;
write(a[i]:3);
end;
writeln();
for i:=1 to n do if (a[i] mod 3=0) and (a[i]<>0) then k:=k+1;
writeln(k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?