В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ivannadyudina2
ivannadyudina2
27.11.2021 17:03 •  Информатика

Составьте программу вычисления суммы элементов массива от второго положительного и до конца я составил такой код, но вот только сумму он определяет не так. есть какие-то идеи? program qq; const n=10; var a: array[1..n] of integer; i,p,j,sum: integer; begin for i: =1 to n do begin a[i]: =random(20)-10; write(a[i],' '); end; j: =0; for i: =1 to n do begin if a[i]> 0 then j: =j+1; if j = 2 then p: =i; end; for i: =p+1 to n do sum: =sum+a[i]; writeln(); writeln('сумма элементов от второго положительного: ',sum); end.

Ответ:
Lolkek3332
Lolkek3332
18.09.2020 11:49
У вас что-то слишком сложная структура для такой задачи.
Предлагаю вариант покороче, скрин и исходник в приложении.
Складывает все числа (положительные и отрицательные) начиная со второго положительного включительно, то есть второй элемент так же будет задействован.

Составьте программу вычисления суммы элементов массива от второго положительного и до конца я состав
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?