В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zhan1205
zhan1205
01.05.2023 07:42 •  Информатика

Pascal! составьте программу для нахождения среднего арифметического положительныхи кратных 3 элементов d размером n: m

Ответ:
Alpetrova7
Alpetrova7
31.07.2020 12:04
// PascalABC.NET 3.0, сборка 1088
const
  nn=30;
  mm=30;
var
  d:array[1..nn,1..mm] of integer;
  m,n,i,j,s,k:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(n,m);
  Randomize;
  Writeln('*** Исходный массив ***');
  s:=0; k:=0;
  for i:=1 to n do begin
    for j:=1 to m do begin
      d[i,j]:=Random(101)-50;
      Write(d[i,j]:4);
      if (d[i,j]>0) and (d[i,j] mod 3 = 0) then begin
        s:=s+d[i,j]; Inc(k)
        end
      end;
    Writeln
  end;
  Writeln('Искомое среднее равно ',s/n:0:5)
end.

Тестовое решение:
Введите число строк и столбцов массива:
10 12
*** Исходный массив ***
  23 -50  24 -15 -43  49 -50 -23  37 -42  36 -40
  13 -37 -47 -47 -17  18  27  39 -30 -13  44 -12
 -20  45   9  44  -6 -17  49  27   3 -19 -11  39
  37 -39  37   8   8 -16 -48 -28 -19  45   2 -30
   6 -19  17  17 -11  -7 -31 -15 -44 -15 -46 -38
 -11 -43  33   3 -40 -42   8 -18  24 -36 -34 -29
  32 -31 -20  37 -15  21 -43 -14  -8 -11 -12 -37
  16 -19 -12 -41 -38 -46  32   1 -43  25 -31   1
   1  -1 -38 -28 -13 -30  -4  -9 -36  -4  36 -31
 -37 -17 -50 -15 -22  18  20 -50  20  20  38  29
Искомое среднее равно 45.30000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?