В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
runeto
runeto
15.03.2020 22:33 •  Информатика

Дано четырехзначное число. написать программу, которая определяет максимальную цифру числа

Ответ:
garua
garua
03.10.2020 01:34
#include <iostream>
using namespace std;

int main(){
    int n;
    int max;
    cin>>n;
    max=0;
    for(int i=1;i<5;i++){
            if((n%10)>max){
                         max=n%10;
            }
            n=n/10;
            }
    cout<<max;
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?