В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
karas14
karas14
13.12.2020 04:08 •  Информатика

Для решения задать случайным образом одномерный массив размерности n (вводится с клавиатуры) из целочисленных элементов, принадлежащих отрезку [-20; 20]. вывести на экран промежуточные результаты, полученные при вычислении значения заданного выражения. составить программу для вычисления t=(r/(q+1))+s r - наименьший элемент массива; q - произведение элементов массива с нечетными номерами; s - количество элементов, лежащих в интервале (a,b) (ввести с клавиатуры).

Ответ:
jonjonson
jonjonson
07.09.2020 09:59
Var C:array[1..100] of Integer;
i,N,Q,R,A,B:integer;
T:real;
begin
Readln(N,A,B);
For i:=1 to N do
C[i]:=Random(-20,20);
R:=C[1];
Q:=1;
For i:=1 to N do
begin
If C[i]<R then
R:=C[i];
If C[i] mod 2=1 then
Q:=Q*C[i];
If (C[i]>A) and (C[i]<B) then
S:=S+1;
end;
T:=(R/(Q+1))+S;
Writeln(R,' ',Q,' ',S,' ',T);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?