В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Hothhgggvhn
Hothhgggvhn
13.04.2020 21:35 •  Информатика

Даны две строковые величины. написать программу подсчета букв 'в' в меньшей по длине величина. в случае равенства длин напечатать значение количества букв 'в' в каждой строковой величине.

Ответ:
Shkolnik98rus
Shkolnik98rus
19.08.2020 08:47
Var n, m: integer;s,d:string;
procedure fd (var z:string;t:integer);
var i,k:integer;
begin
for i := 1 to t do begin
if z[i] = 'в' then k:= k +1;end;
writeln(k);end;
Begin
d:='Написать программу подсчета букв "в" в меньшей по длине величина ввв прпрпрп ролроллолшл нг';
s:='В случае равенства длин напечатать значение количества букв "в" в каждой строковой величине';
n:=length(s);m:=length(d);
if n = m then begin fd(d,m);fd(s,n);end
else if n < m then fd(s,n)
else fd(d,m);End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?