В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lizochka2007u
Lizochka2007u
13.07.2021 09:42 •  Информатика

Написать программу , которая считает, сколько раз последовательности из 10 чисел встречается введённое с клавиатуры число а.

Ответ:
mrfotuna14
mrfotuna14
17.09.2020 23:15
Var i,k,n: integer;
    a: array[1..10] of integer;
begin
  k:=0;    randomize;
  writeln('число:  '); readln(n);
  writeln('последовательность из 10 элементов');
  for i:=1 to 10 do
  begin
    a[i]:=random(50);
    write(a[i],' ');
    if a[i]=n then k:=k+1;
  end;
  writeln;
  if k>0 then
      writeln('число ',n,' встречается ',k,' раз')
  else
      writeln('числа ',n,' нет в последовательности');
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?