В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
TemhenkoShasa
TemhenkoShasa
05.11.2020 14:35 •  Информатика

Даны целое трехзначное число n и цедое число k. написать программу, подсчитывающую сумму цифр числа n, которые больше k

Ответ:
Кирилл62а
Кирилл62а
17.09.2020 16:24
Var N,k,sum : Integer;
Begin
  sum:=0;
  Readln(N,k);
  While N>0 do
  Begin
   If (N mod 10)>k then sum:=sum+(N mod k);
   N:=N div 10;
  end;
end.

или так

Var N,k,sum : Integer;
Begin
  sum:=0;
  Readln(N,k);
  While N>0 do
  Begin
   sum:=sum+(N mod 10)*Ord((N mod 10)>k);
   N:=N div 10;
  end;
end.

или так

Var N,k : Integer;
Function sum(N,k : Integer) : Integer;
Begin
  If (N>0) and ((N mod 10)>k) then sum:=(N mod 10)+sum(N div 10,k) else sum:=0;
end;
Begin
  Readln(N,k);
  Writeln(sum(N,k));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?