В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sgymgjvb
sgymgjvb
16.05.2020 13:57 •  Информатика

Склавиатуры одной строкой вводят имя и фамилию. составьте программу, которая определяет, есть ли во введенной строке заданный символ

Ответ:
sofiko07161
sofiko07161
06.06.2020 21:45

var
slovo,simval:string;
i,k:integer;
begin
k:=0;
 write('Введите имя и фамилию ');
readln(slovo);
write('Введите символ ');
readln(simval);
for i:=1 to length(slovo) do
begin
if slovo[i]=simval then k:=k+1;
if slovo[i]=simval then writeln(i,' ');
end;
if k>=1 then
 writeln('Да, встречается ',k,' раз, на позиции ',i)else writeln('Нет');
end.

 

 

Я немножко перевыполнил) От показывает есть симаол или нет, если есть то сколько раз он входит и на какой позиции... 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?